A general unexpected error has occurred:


Good morning,

Here’s the rest of the error

error: couldn’t connect to server: EOF reached (code 1)
(make sure server is running and you are connecting to the correct RPC port)
See the console/logfile output for more detailed error information!

edit: sorry I’m getting this error when attempting to start the GUI wallet


Hi everyone,

I had a Swing wallet running perfectly for a few days. Starting from yesterday I am not able to use it.
I’ve got the following error:


Can the support team help to find solution? Thanks for support.


I searched further through the support threads and found that a zend -reindex worked (took a copy of my wallet.dat first). I have new t addresses now though and I need to get to the old one to transfer some funds out. How is this done?


If you did not delete the original wallet.dat file then you should not have a new/different T address in the wallet after re-indexing. Since this problem sounds strange, before attempting any more repairs make sure you have a safe backup copy of the original wallet.dat file. It may be copied manually when the GUI wallet/zend are not running. The wallet.dat needs to be backed up regularly (not just once - say after every 30-40 outgoing transactions) and it MUST also be backed up after creating a new Z address.


This appears to be the known problem of a broken/corrupt block-chain. In most cases it can be fixed safely. Some manual repairs will be necessary.

The ZEN private keys are located in the wallet.dat file in directory:
Windows: %APPDATA%/Zen/
Mac OS: ~/Library/Application Support/Zen/
To make sure your ZEN is not lost, the most important thing is to keep a backup copy of your wallet.dat file - it must never be lost! It may be copied manually when the GUI wallet/zend are not running. The wallet.dat needs to be backed up regularly (not just once - say after every 30-40 outgoing transactions) and it MUST also be backed up after creating a new Z address.

Once you make sure you have a wallet backup in a safe place, this problem is most commonly solved by re-indexing the block-chain. For details of how to reindex, see the troubleshooting guide: https://github.com/ZencashOfficial/zencash-swing-wallet-ui/blob/master/docs/TroubleshootingGuide.md


I am having this same exact problem. I installed the ZenCash wallet on another laptop and tried to copy and paste the wallet.dat file from the previous computer into the new instance, but that didn’t work, and now the ZenCash Wallet has the same error message again, and cannot be launched (even though I swapped back the original Wallet.dat file. How to I recover my ZenCash and escape from this problem? I tried to understand how to run the reindex but don’t know how to get the command to start at the command prompt (using latest windows). Any help would be greatly appreciated.


The following step-by-step guide for Windows users (created by a third party) is handy: https://miningwithnvidia.com/2018/02/09/zencash-wallet-eof-reached-code-1/
to help with reindexing in case of encountering the common block-chain problem.


Thank you. I finally understood how to do this. So I started the process and it ran for 8 hours 47 minutes, and then I clicked on the scroll bar on the right side of the window out of curiosity, and it froze. Is it still running in the background? How do I restart from where it stopped? Please help.
Thank you


Just to update you. I started all over again. Will it say it’s completed when it’s done? Is there any message that will appear?


zend does not stop when re-indexing is complete and it does not give any special indications of it. It just continues to work normally after re-indexing. If you start the GUI wallet and it shows a 100% blockchain synchronization, then you can be sure re-indexing is complete.


Well remember…the reason I did this entire exercise is my GUI would not open.

Is there something I can look at to see if it’s done? Right now it reads:

You have validated 3412948 transactions
Block height | 259771
Network Solution rate | 46150794 Sol/s

The Last block on WTM is

So do I now hit Ctrl C and close the window?



Hey, this has been a bad experience for me, and I was thinking to move all my ZenCash back to Bittrex. It cost me 4 days of hassle to fix this issue and a lot of stress.

a) Are you going to massively improve this wallet?

b) If not, can you recommend another better wallet? Will any other hardware wallets allow storage of ZenCash soon?

I don’t mean to insult you since you’re the creator of this wallet, but this is VERY FAR from user-friendly.


The GUI wallet was generally stable before the “broken blockchain” problems started. If you are experiencing the “broken blockchain” too often, unfortunately only other option is maybe to use a different wallet like Arizen that does not have the problem:

The underlying technical cause is not in the GUI itself but in the ZEN core/node. The problem is being investigated as a priority by the ZEN core team. It started occurring recently with high frequency without any software changes - it is related to network load/transactions/block content. Once a fix is made available a new wallet release will be made. The workaround to do reindexing is not very convenient but still allows uses to recover from the problem.


A new release of the ZEN core node has been made that contains a stability fix for the “broken blockchain” problems that many users have experienced recently, that cause the GUI wallet to fail on startup:

This new ZEN core version will be used in the next GUI wallet releases to fix the problem. Users who do not wish to wait for a new GUI wallet release may use the new ZEN core/node binaries by replacing them in the GUI wallet installation manually. Some details on how to do this: the ZENCash Desktop GUI Wallet includes a full ZEN node and the UI is in effect an interface to the locally running ZEN node. The ZEN node binaries are located in:

Mac OS (absolute file paths):

Windows: having as a base directory the place where the GUI wallet was unzipped from ZENCashDesktopGUIWallet_0.75.8.zip the binaries are:

If a user has experienced the “broken blockchain” problem more than once before he may replace the ZEN binaries with the ones from the latest release to gain better stability.

Note: If the ZEN blockchain is currently in a broken state, even with the new/fixed binaries users may have to do one final reixdexing operation to avoid the problems. For details on how to reindex the following articles may be consulted:


Where can I find zend.exe on windows10


The path is /app/zend.exe below the directory where you unzipped the wallet e.g. it could be: ZENCashDesktopGUIWallet_0.80.5/app/zend.exe