Wallet won't open. Error


I receive the above error upon opening my wallet. I tried to uninstalling and downloading again. I have my wallet.dat safe but cannot open the program.


This appears to be the known problem of a broken/corrupt block-chain. In most cases it can be fixed safely. Some manual repairs will be necessary.

The ZEN private keys are located in the wallet.dat file in directory:
Windows: %APPDATA%/Zen/
Mac OS: ~/Library/Application Support/Zen/
To make sure your ZEN is not lost, the most important thing is to keep a backup copy of your wallet.dat file - it must never be lost! It may be copied manually when the GUI wallet/zend are not running. The wallet.dat needs to be backed up regularly (not just once - say after every 30-40 outgoing transactions) and it MUST also be backed up after creating a new Z address.

Once you make sure you have a wallet backup in a safe place, this problem is most commonly solved by re-indexing the block-chain. For details of how to reindex, see the troubleshooting guide: https://github.com/ZencashOfficial/zencash-swing-wallet-ui/blob/master/docs/TroubleshootingGuide.md

The following step-by-step guide for Windows users (created by a third party) is also handy: https://miningwithnvidia.com/2018/02/09/zencash-wallet-eof-reached-code-1/ to help with reindexing in case of encountering the common block-chain problem.

Finally to avoid a repetition of the problem you need Windows wallet version 0.75.8a or later.