Zencash wallet error on startup on mac


I just tried to open the Zencash wallet and I received a critical error message saying:

Blockquote A general unexpected critical error has occurred: error: couldn’t connect to server: unknown (code -1) (make sure server is running and you are connecting to the correct RPC port). See the console/logfile output for more detailed error information!

Any ideas on how to fix this? I’m using a mac. Thanks very much for your help!


This appears to be the known problem of a broken/corrupt block-chain. The underlying technical cause is not in the GUI itself but in the ZEN core/node. This problem is most commonly solved by re-indexing the block-chain. For details of how to reindex, see the troubleshooting guide: https://github.com/ZencashOfficial/zencash-swing-wallet-ui/blob/master/docs/TroubleshootingGuide.md The workaround to do reindexing is not very convenient but still allows uses to recover from the problem.

To make sure the problem does not happen repeatedly you need to use the latest wallet version for Mac OS - 0.75.9a that includes ZENCash 2.0.11 binaries.

The ZEN private keys are located in the wallet.dat file in directory:
Windows: %APPDATA%/Zen/
Mac OS: ~/Library/Application Support/Zen/

To make sure your ZEN is not lost, the most important thing is to keep a backup copy of your wallet.dat file - it must never be lost! It may be copied manually when the GUI wallet/zend are not running. The wallet.dat needs to be backed up regularly (not just once - say after every 30-40 outgoing transactions) and it MUST also be backed up after creating a new Z address.


Thank you very much for your help. I just checked the directory at:

~/Library/Application Support/

There is no file or folder called ‘Zen’ or ‘ZencashSwingWalletUI’ . Any ideas why this isn’t there and/or how to fix this?


If the GUI wallet starts but shows the error above, I find it hard to believe that the directory ~/Library/Application Support is empty. Please open a terminal and type the command:

ls -lh ~/Library/Application\ Support

and please see if it shows any Zen*/ZEN* directories.


I have the same issue. When I search USER Library Application Support there is no Zen listed. I tried the terminal and it shows: drwxr-xr-x 8 StevenThompson staff 272B Feb 2 17:18 ZENCashSwingWalletUI and
drwxr-xr-x 15 StevenThompson staff 510B Feb 25 21:09 Zen

I did a search for wallet.dat and could not find it. Any assistance would be much appreciated


So if your terminal shows:

drwxr-xr-x 8 StevenThompson staff 272B Feb 2 17:18 ZENCashSwingWalletUI
drwxr-xr-x 15 StevenThompson staff 510B Feb 25 21:09 Zen

you have the expected directories. The wallet.dat file is contained inside the Zen directory that is listed. The full path to the wallet file is:

~/Library/Application Support/Zen/wallet.dat

If you cannot find it using the Mac finder UI tool, perhaps you can back it up using a terminal with the cp command. Here is one nice tutorial for beginners on how to use terminal on a Mac:


Thanks for your help. I searched how to see hidden files on a Mac and was able to find the wallet.dat file